Google SketchUp Basics for K-12 Education
**Table of Contents**
A look at all of the class content at a glance.

<table>
<thead>
<tr>
<th>Page</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>04</td>
<td>Introduction</td>
</tr>
<tr>
<td>06</td>
<td>Doghouse Tutorial</td>
</tr>
<tr>
<td>15</td>
<td>Creating Geometry</td>
</tr>
<tr>
<td>22</td>
<td>Modifying Geometry</td>
</tr>
<tr>
<td>26</td>
<td>Schoolhouse Tutorial</td>
</tr>
<tr>
<td>34</td>
<td>Sharing</td>
</tr>
<tr>
<td>38</td>
<td>Resources</td>
</tr>
</tbody>
</table>
:: Overview
Google SketchUp is an extremely powerful 3d modeling tool useful for presenting geometric concepts and exploring 3d space in the classroom. The free version of SketchUp offers most of the same tools used by professional architects all over the world. SketchUp’s familiar pencil and paper paradigm presented in a software context makes it easy for anyone to use this tool. This course is intended for students with little or no 3d experience, who want to learn how to build 3d models in Google SketchUp.

:: Prior Skills
To be successful, in this course you should already be able to:
• Define fundamental geometric terms including: polygon, parallel, perpendicular, axes, and arc.
• Demonstrate fundamental computer skills including: start an application, copy files to the desktop, internet navigation.
• Demonstrate mouse skills including: double-click, single-click, drag, and right-click (context-click).
• You will need a basic 3-button scroll wheel mouse to use SketchUp

:: Learning Objectives
Upon completion of this course you should be able to:
• Create 2d geometry in a 3d environment
• Create 3d geometry
• Navigate a model in 3D
• Create surfaces from lines in 3D
• Create geometry with the Push/Pull Tool
• Maintain coplanar geometry
• Lock inferences
• Create a model, step-by-step
• Create a copy and an array
• Apply materials
• Import models from the Google 3D Warehouse
• Share your model with the world using the 3d Warehouse
Google SketchUp is an extremely powerful 3d modeling tool. SketchUp is used to explore 3d space, illustrate complex spacial situations, build and explore digital prototypes, explain math concepts, measurements, and much more. Understanding the basics of the program is the first step to mastering SketchUp. Today we will cover just that, the basics, and get you started quick into 3d modeling. This will allow you to go back and teach your students the same concepts. We will also provide the resources necessary to continue on beyond the basics after today’s class, and also everything you need to teach this class.

**Introduction**
Why SketchUp?

- **Copy Class Files**
  Copy all class files to your desktop for easy access during class.

- **Launch SketchUp**
  Open SketchUp from the icon on your desktop, or from the Start bar.
Choose Template
In the Template dropdown, select the “Simple Template - Feet and Inches”. Next click on “Start using SketchUp”. You can also select a template from the Window dropdown > Preferences > Template.

Orbit
Push down on the scroll wheel button to navigate around your model.

Pan
Push down on the scroll wheel button and hold down the Shift key to slide your screen up, down, left and right. (Opt on Mac?)
Let’s get started in 3d! We will begin by creating a doghouse with very exact step by step instructions. We want you to realize how easy it is to use SketchUp and create a real model, real fast!

**Zoom**

Roll the scroll wheel forward and backward to zoom in and out.

**Draw Site**

1) Using the Rectangle tool, click (and release) on the origin. 2) Move cursor away from the starting point towards the top right of your screen and let go of the mouse. 3) Type [10’,10’ Enter] to finish.
Using the Rectangle tool, draw another rectangle somewhere in the middle of the first rectangle with the dimensions of 3’ by 5’. This will be the footprint of our doghouse.

**Draw Footprint**

1) Using the Push/Pull tool, click once on the doghouse footprint.
2) Move your cursor away from the starting point and let go of the mouse.
3) Type [3’ Enter]. This will pull the rectangle up by 3’ exactly.

**Push/Pull Up**

1) Using the Line tool, click once on the midpoint on the top front edge of the box.
2) Move your cursor to the midpoint of the top back edge and click again to finish.

**Draw a Line**
Move
1) Using the Move/Copy tool, hover on the middle edge, click once to start the move.
2) Move your cursor up and away from the starting point and find the blue axis.
3) Let go of the mouse, type [Enter].

Create Roof
1) Using the Push/Pull tool, click on the roof surface to start.
2) Tap Ctrl (Opt on Mac) to leave a copy of the starting face.
3) Move cursor in the desired direction of the pull, let go of mouse.
4) Type [Enter].

Create Roof
Using the Push/pull tool, double on the other top angled surface to pull out by 4”. The Push/Pull tool has a memory that stores the last input. We access this memory by double clicking.
Finish Roof
1) Using the Push/Pull tool, finish the roof by clicking once on the top surface. 2) Move cursor away from start point and hover cursor over the endpoint, click to finish.

Roof Overhangs
Using the Push/Pull tool, double click on all roof fascias to create overhangs. The Push/Pull tool has a memory so all overhangs will be 4”.

Create Front Door
1) Using the Rectangle tool, click once on the bottom front edge ("On Edge" inference) of the doghouse. 2) Move cursor away from starting point and click on the surface ("On Face" inference).
1) Select the Paint Bucket tool. This automatically launches the Materials Browser which allows us to select, organize, and save materials.

2) Click on the Material Library dropdown and choose “Roofing”.

---

**Add an Arc**

1) Using the Arc tool, click once on the top left corner of the rectangle.
2) Click again on the top right corner of the rectangle.
3) Move cursor up until you see the “Half Circle” inference, click to finish.

**Finish Front Door**

Using the Push/Pull tool, double click on both the rectangle and the arc to indent the front door.

**Material Browser**

1) Select the Paint Bucket tool. This automatically launches the Materials Browser which allows us to select, organize, and save materials.
2) Click on the Material Library dropdown and choose “Roofing”.

---
Select a Material
Click once on a material in the material browser, then click on a surface in your model.

Apply Materials
Apply materials from several libraries. 1) Roofing, 2) Brick and Cladding, 3) Colors, 4) Vegetation. There is no need to “erase” a material from a surface. To change materials, just paint the surface again.

Edit Material
1) Select the “In Model” library, double click on the siding material. Use slider bars and text input boxes to adjust properties. 2) On Mac, use the icons at the top to edit different properties, start with the brick.
1) Using the circle tool, click on the ground to set the center point of the circle.  2) Move the cursor away from the center point, in any direction, and let go of the mouse.  3) Type [6 Enter].

**Water Bowl**

1) Using the Push/Pull tool, click once on the circle to start.  2) Move cursor up and away from the starting point, let go of mouse.  3) Type [4 Enter]. Also, you could double-click if 4” was your last Push/Pull.

**Push/Pull**

1) Using the Offset tool, click once on the top of the bowl to start.  2) Move your cursor towards the inside of the circle, let go of the mouse.  3) Type [1 Enter].

**Offset**
**Push/Pull**
1) Using the Push/Pull tool, click once on the top middle circle to start. 2) Move cursor down, let go of mouse. 3) Type [3 Enter]

**Apply Material**
Using the Paint Bucket Tool, apply the trim material to all faces of the water bowl.

**Push/Pull**
1) Using the Push/Pull tool, click once on the bottom of the water bowl. 2) Tap Ctrl (Opt on Mac) and move cursor up and away from starting point, let go of mouse. 3) Type [2 Enter].
Activate the Paint Bucket tool. In the Materials Browser select the Water library, then the “Water_Sparkling” material. Apply this material to the top circle of the water bowl.

Add Water

Click on the Window dropdown menu and choose “Components”. Select the “Components Sampler” collection from the collections dropdown.

Components Browser

Click on the “2d Girls Dog” component in the Components Browser, then click again in your model to place the component. Try adding other components.

Add Components
Now that we have had our first taste of 3d, let’s take a look at what makes SketchUp work so well. It is important to understand the fundamentals of SketchUp to eventually master this program. In this chapter we will explore the main drawing tools available in SketchUp.

Choose Template
Under the Window dropdown menu (SketchUp dropdown on Mac) choose “Preferences > Template”. Select “Beginning Training Template - Inches”. Next, start a new document.

Rectangle
1) Using the Rectangle tool, click once on the origin to start. 2) Move cursor to top right of screen. 3) Notice that the Rectangle tool snaps to a square and a golden section. 4) Let go of mouse and type [5’, 5’].
1) Using the Line tool, click on endpoint. 2) Move cursor down on green axis, then type [5’ Enter]. 3) Hover on endpoint to encourage inference. 4) Click on inference intersection. 5) Click on endpoint.

Drawing with Inferences

In order for a surface to exist in SketchUp there must be a closed loop of coplanar edges. 1) Delete an edge to break the loop. 2) This will also delete the surface.

Surfaces

1) Using the Line tool, click once on endpoint to start. 2) Click on endpoint to finish. By closing the loop of coplanar edges, you re-create the surface.

Re-create a Surface
**Delete a Surface**

To delete a surface, right click on the surface and choose delete. You can also preselect with the select tool, then press delete on your keyboard. The eraser tool will not affect surfaces.

**Re-heal a Surface**

1) Using the Line tool, click once on endpoint to start. 2) Click on endpoint to finish. Retracing any edge on a closed loop of coplanar edges will re-heal a surface.

**Divided Surfaces**

1) Notice that you have two separate surfaces divided by the line between. 2) By deleting the dividing line you can weld the surfaces together. 3) Test this concept with the selection tool.
1) Hover on endpoint of rectangle to encourage inference. 2) Move cursor away and click to define center point of circle. 3) Move cursor away from center point and click to define radius.

**Circle with Inferences**

**Arc**
1) Click on endpoint to start. 2) Click on Midpoint. 3) Move cursor in desired direction of arc. Either click to define bulge, or enter an exact value such as [3’ Enter].

**Polygon**
1) Define the number of sides by typing a number, then “s”. For a hexagon type [6s Enter]. 2) Click to define center point of polygon. 2) Move cursor away from center point and click to define radius.
**Freehand**

1) Using the Freehand tool, click and hold “On Edge” to start.  
2) Drag the cursor to draw an abstract shape.  
3) Position the cursor “On Edge” and release click to finish.

**Erase**

Use the Eraser tool to clear everything off of your screen. Try clicking on individual edges to erase one at a time. Also, click and drag across multiple edges to delete many with one click.

**Rectangle**

1) Using the Rectangle tool, click on origin to start.  
2) Move cursor away from starting point, let go of mouse, type [10',5' Enter].
**Orbit into 3d**
Using your 3 button scroll wheel mouse, push down on the scroll wheel and slide mouse to navigate into a 3d view.

**Drawing on Axis**
1) Using the Line tool, click on endpoint. 2) Tap the up arrow key, move cursor up, let go of mouse, type [3’ Enter]. 3) Move cursor back, tap left arrow key. 4) Click on endpoint. 5) Click on endpoint again.
**Drawing on Axis**

1) Using the Line tool, click on endpoint. 
2) Hover on endpoint to encourage inference. 
3) Click where axis and inference line intersect. 
4) Click on endpoint to finish.

**Complete the Form**

1) Using the Line tool, click on endpoint to start. 
2) Click on endpoint to finish. If drawn properly on axis both the top and side surfaces will fill in.

---

**5 MINUTE EXERCISE ::** Explore tools on your own. Open the Instructor from the Window drop-down menu, choose “Instructor”. This will help you explore tools in SketchUp.
Modifying Geometry
Some basic tips for using SketchUp’s editing tools.

Now that we know how to create geometry, let’s explore how we can modify geometry. In the next chapter we will look at the tools that change geometry that we have already created. These tools allow you to generate very complex forms with very little effort!

New Document
Click on the File dropdown and select “New” to create a new document. There is no need to save any changes.

Rectangle
1) Using the Rectangle tool, click once on the origin to start. 2) Move cursor away from starting point, let go of mouse, type [3’,3’ Enter].
**Move**

1) Using the Move/Copy tool, hover over the square surface to autoselect. Click once to pick it up. 2) Move cursor to top left of screen, click again to put it down.

**Copy**

1) Using the Move/Copy tool, click once to pick it up. 2) Move cursor to the right on the red axis, tap control to leave a copy behind, click again to put it down. 3) Let go of mouse, type [5' Enter] for exact distance.

**Array**

1) Using the Move/Copy tool, perform the exact same set of commands as the previous copy. 2) Immediately after you enter the exact distance, type [5x Enter] to create 5 additional copies.
**TIP ::** You can also make a copy and array based on divisions. Try copying the square all the way to the right edge of your screen, then type [5/ Enter]. This will create 5 equal divisions between the copied objects.

**TIP ::** You can also make a rotate copy, and copy and array based on copies or divisions, just like the Move/Copy tool! Reference the Instructor for some more advanced operations and tutorials.

---

**Rotate**

1) Using the Rotate tool, hover on a square and click once to set the center of rotation.  2) Move your cursor down and click to set the reference point.  3) Move cursor to rotate object and click to finish.
Open Document

On the File dropdown menu choose “Open”. Select the “EDU Tutorial - Follow Me.skp” from the EDU Class Files folder on your desktop. No need to save changes.

Follow Me

1) Complete the Follow me exercises by following the on screen instructions.

2) Move to the next exercise by clicking on the numbered scene tabs at the top of the screen.

5 MINUTE EXERCISE :: Try using the follow me tool with your own profiles and paths. This is the last scene in the “EDU Tutorial - Follow Me.skp”.

Copyright © 2002-2010 Google, Inc.
Schoolhouse Tutorial
From a doghouse to a schoolhouse.

:: SketchUp is used by major architectural firms all over the world to explore buildings before they are constructed. Would you believe that the same toolset that professionals use is available to you! Let’s put that toolset to work and build a more complex structure, like a schoolhouse!

New Document
Click on the File dropdown menu and choose “New” to start a new document. No need to save changes.

Rectangle
1) Using the Rectangle tool, click once to start the rectangle. 2) Move cursor away from starting point. 3) Let go of mouse and type, [50’,100’ Enter].
Click on the Zoom Extents tool in the Large Toolset. This will center all geometry in your SketchUp model on your screen. Now orbit into a 3d view.

**Building Footprint**

1) Using the Push/Pull tool, click once on the rectangle.
2) Move your cursor up, let go of the mouse, type [30' Enter].

**Create Massing**

1) Using the Offset tool, hover on the top rectangle, click to start offset.
2) Move cursor to the inside of the rectangle, let go of mouse, type [10' Enter].

**Create Roof**
**Move with AutoFold**

1) Using the Move tool, click once on the middle rectangle to start the move. 
2) Tap the up arrow key to lock the blue axis and toggle on the AutoFold command. 
3) Move your cursor up, let go, type [10’ Enter].

**Create Parapet Wall**

1) Using the Offset tool, hover on the edge of the top rectangle, click to start offset. 
2) Move cursor to the inside of the rectangle, let go of mouse, type [1’ Enter].

**Create Parapet Wall**

1) Using the Push/Pull tool, click once on the top rectangle. 
2) Move your cursor down, let go of the mouse, type [3’ Enter].
1) Using the Push/Pull tool, click once on the side. 2) Move your cursor in, let go of the mouse, type [2’ Enter]. Now, double click on other sides of the building to create all overhangs.

Roof Overhangs

Using the Eraser tool, erase all of the unnecessary edges on the roof overhangs. Orbit under your model and zoom in utilize a more strategic view while completing this task.

Cleanup

1) Using the Push/Pull tool, click once on the bottom of the roof overhang to start. 2) Move your cursor down, let go of the mouse, type [12” Enter].

Roof Fascia
Using the Paint Bucket tool, apply materials to your model. Select from the following libraries to create the image above: Brick and Cladding, Roofing, Colors, Vegetation, Ground Cover.

**Draw Site**
1) Using the Rectangle tool, click once at the bottom left corner of your screen.
2) Move cursor to top right corner of your screen and click to finish.

**Draw Sidewalk**
1) Using the Rectangle tool, click once on the bottom front edge of the schoolhouse.
2) Move cursor to edge of site and click to finish. Be sure to start and finish the rectangle with an “On Edge” inference.

**Add Materials**
Using the Paint Bucket tool, apply materials to your model. Select from the following libraries to create the image above: Brick and Cladding, Roofing, Colors, Vegetation, Ground Cover.
1) Click on the Window dropdown menu and choose “Components”.  
2) Search in the Component Browser for “EDU Tutorials”.  
3) Click on the icon to see the models contained in this collection.

Component Browser

Add Door
1) Click on the “EDU Door” component in the Component Browser.  
2) Find the midpoint of the bottom edge on the front elevation, click to place.

Add Window
1) Click on the “EDU Window” component in the Component Browser.  
2) Position the window on the top left corner of the front elevation, click to place.
**Copy and Array**

1) Using the Move/Copy tool, click on the window, tap Ctrl (Option on Mac).
2) Tap the right arrow key to lock the red axis, move the copy to the end of the building, click to place.
3) Type [4/ Enter].

**Copy All**

1) Using the Select tool, hold Shift, select all windows.
2) Using the Move/Copy tool, click on a window, tap Ctrl (Option on Mac).
3) Tap the up arrow key to lock the blue axis, move copies down, click to place.

**Add Small Window**

1) Click on the smaller “EDU Window” component in the Component Browser.
2) Position the window on the bottom left corner of the front elevation, click to place.
**Copy and Array**

1) Using the Move/Copy tool, click on the window, tap control (option on Mac).  
2) Move the copy on the red axis to the end of the building, click to place.  
3) Type [2/ Enter] to make 2 copies with equal divisions.

**Copy All**

1) Using the Select tool, select all small windows.  
2) Using the Move/Copy tool, click once on any window, tap Control (Option on Mac).  
3) Move the copies to the other side of the front elevation.

---

**5 MINUTE EXERCISE ::** Add windows and doors to the other sides of the schoolhouse. Also add bushes, trees, students, and the flagpole from the EDU Tutorial component collection to make the model come alive.
Everyone, especially kids, loves to create an object that they can touch, show friends, display in the hall, or hang on the fridge. SketchUp gives us the tools to create images for print and email. We also have the ability to create animations for email, or even creating DVD’s and sharing on YouTube. Furthermore, we are even able to share our digital SketchUp creations with the world through the 3D Warehouse! Now that we have created a real project in SketchUp, let’s share it!

**Select a View**

Using the Orbit tool, navigate to a view that you would like to print. Also, try using the Walk and Lookaround tools to set up a realistic view that a human would actually experience.

**Create an Image**

Under the File dropdown choose “Export > 2D Graphic...”. Save the image to the Class Files folder on your desktop. Now, open the file to see what you have created.
1) Click on the Window dropdown menu and choose “Scenes” to open the Scenes palette.  
2) Click on the plus sign to add a scene. Now you can always get back to this view by clicking on the scene tab.

**Scenes**

---

**Orbit to Another View**

Using the Orbit tool, navigate to the other side of your schoolhouse.

---

**Add Another Scene**

1) Click on the add scene button again. This view is now saved as well.  
2) Now, click on the first scene tab at the top of the screen and you will see an animation between the two scenes you created.
Click on the File dropdown menu and choose “Export > Animation”. Now Click on the Options button at the bottom right of the window. Set the resolution and frame rate as desired. Click “OK”.

**TIP ::** Control your animation by modifying Options in the Export window and also in the Model Info dialogue box. Access Model info by clicking on the Window dropdown menu and choosing “Model Info”. Longer scene transitions mean a slower flying camera. Scene delay will set the amount of time to stop at each scene.

**Export Animation**

Click on the File dropdown menu and choose “Export > Animation”. Now Click on the Options button at the bottom right of the window. Set the resolution and frame rate as desired. Click “OK”.

**Save Animation**

Save the animation to the Class Files folder on your desktop. Typically you want to leave the file type as .avi, or .mov on Mac.
Sharing with the World

Click on the Share Model button in the Google Toolbar. Either sign in with your current Google account, or click on the “Create an account now” to create a new Google account.

Purge Model

If prompted to purge your model, choose “Yes”. This will keep your file size low, download times fast, and keep unnecessary information off of the 3d Warehouse.

3d Warehouse

Fill in all required fields in the model details window. Add Tags to your model to help others search for and find your creation.
**TIP ::** Manage your 3d Warehouse content by creating collections. These are similar to folders in a typical file structure.

**Resources**
Valuable websites and additional information.

- **3d Vinci**
  http://www.3dvinci.net/

- **Sketchy Physics**
  http://code.google.com/p/sketchy-physics/
Notes
Record your own tips, tricks, and strategies.